flutter_exceptions_redux 0.0.3
flutter_exceptions_redux: ^0.0.3 copied to clipboard

Exception handling state and middleware for redux in Flutter.

0
likes
90 / 130
pub points
28 %
popularity

We analyzed this package on May 12, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 33 API elements (12.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_redux>=0.6.0 <1.0.00.7.00.8.2
json_annotation>=3.0.1 <4.0.03.1.14.0.1
json_serializable>=3.2.5 <4.0.03.5.14.1.1
redux>=4.0.0 <5.0.04.0.0+35.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.021.0.0
analyzer-0.41.21.5.0
args-2.1.02.1.0
async-2.6.12.6.1
build-1.6.22.0.1
build_config-0.4.71.0.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
checked_yaml-1.0.42.0.1
cli_util-0.3.00.3.0
collection-1.15.01.15.0
convert-3.0.03.0.0
crypto-3.0.13.0.1
dart_style-1.3.122.0.1
file-6.1.06.1.0
glob-2.0.12.0.1
logging-1.0.11.0.1
meta-1.3.01.3.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
pub_semver-2.0.02.0.0
pubspec_parse-0.1.81.0.0
sky_engine-0.0.990.0.99
source_gen-0.9.10+31.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
watcher-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `>=3.0.1 <4.0.0` on json_annotation does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions json_annotation to update the constraint.

The constraint `>=3.2.5 <4.0.0` on json_serializable does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions json_serializable to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.