flutter_emoji_keyboard 0.1.3
flutter_emoji_keyboard: ^0.1.3 copied to clipboard

A Fast and Light ⚡ Emoji Keyboard ✨ Widget (implements compatible emoji support)

16
likes
80 / 110
pub points
84 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 20 out of 60 API elements (33.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_emoji_keyboard/flutter_emoji_keyboard.dart that imports:
  • package:flutter_emoji_keyboard/src/emoji_keyboard_widget.dart that imports:
  • package:flutter_emoji_keyboard/src/compatible_emojis.dart that imports:
  • package:device_info/device_info.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/emoji_keyboard_widget.dart:31:44

   ╷
31 │   final List<GlobalKey> categoryKeyStore = List(8);
   │                                            ^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/emoji_keyboard_widget.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
device_info^1.0.01.0.02.0.0
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
device_info_platform_interface-1.0.12.0.1
meta-1.3.01.3.0
plugin_platform_interface-1.0.32.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on device_info does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions device_info to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

16
likes
80
pub points
84%
popularity

A Fast and Light ⚡ Emoji Keyboard ✨ Widget (implements compatible emoji support)

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

teamnaji@gmail.com

License

BSD (LICENSE)

Dependencies

device_info, flutter

More

Packages that depend on flutter_emoji_keyboard