flutter_easyhub 1.0.1+0.10
flutter_easyhub: ^1.0.1+0.10 copied to clipboard

easy for hub, When you do a lot of calculation, you need this animation. When you make a network error or finish downloading files, you also need this animation。

3
likes
75 / 110
pub points
61 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 113 out of 476 API elements (23.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/animation/easy_falling_ball.dart:55:29

   ╷
55 │         List<Widget> list = List();
   │                             ^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/animation/easy_falling_ball.dart

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/animation/easy_flashing_circles.dart:48:25

   ╷
48 │     List<Widget> list = List();
   │                         ^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/animation/easy_flashing_circles.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_easyloading^1.1.41.3.03.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
flutter_spinkit-4.1.2+15.0.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.1.4` on flutter_easyloading does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions flutter_easyloading to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

3
likes
75
pub points
61%
popularity

easy for hub, When you do a lot of calculation, you need this animation. When you make a network error or finish downloading files, you also need this animation。

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

fgyong215@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, flutter_easyloading

More

Packages that depend on flutter_easyhub