flutter_device_details 0.0.2 copy "flutter_device_details: ^0.0.2" to clipboard
flutter_device_details: ^0.0.2 copied to clipboard

A flutter project for the Android & iOS device releated information which is necessary for most of the mobile projects targetting Android & iOS.

6
likes
40/ 140
pub points
64%
popularity

We analyzed this package 4 days ago, and awarded it 40 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

These platforms are not supported:

Tag detection failed.

Exception: Couldn't read pubspec.yaml in /Users/nagaraju/Downloads/flutter/packages/flutter. PathNotFoundException: Cannot open file, path = '/Users/nagaraju/Downloads/flutter/packages/flutter/pubspec.yaml' (OS Error: No such file or directory, errno = 2)

Tag detection failed.

Exception: Couldn't read pubspec.yaml in /Users/nagaraju/Downloads/flutter/packages/flutter. PathNotFoundException: Cannot open file, path = '/Users/nagaraju/Downloads/flutter/packages/flutter/pubspec.yaml' (OS Error: No such file or directory, errno = 2)

Package does not support platform `Windows`.

Because:

  • package:flutter_device_details/flutter_device_details.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_device_details/flutter_device_details.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:flutter_device_details/flutter_device_details.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flutter_device_details/flutter_device_details.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running flutter pub outdated failed with the following output:
The lower bound of "sdk: '>=2.7.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.3.3. Cannot run `flutter pub outdated`.

pubspec.yaml:7:8

  ╷
7 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.3.3.

pubspec.yaml:7:8

  ╷
7 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (3.3.3)

pubspec.yaml:7:8

  ╷
7 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

6
likes
40
pub points
64%
popularity

Publisher

unverified uploader

A flutter project for the Android & iOS device releated information which is necessary for most of the mobile projects targetting Android & iOS.

Repository (GitHub)
View/report issues

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_device_details