flutter_data_stream_builder 0.0.6 icon indicating copy to clipboard operation
flutter_data_stream_builder: ^0.0.6 copied to clipboard

A pragmatic StreamBuilder with sensible defaults

9
likes
70/ 140
pub points
56%
popularity

We analyzed this package 4 hours ago, and awarded it 70 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 17 API elements (76.5 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

ERROR: 'DataStreamBuilder.afterError' ('AsyncSnapshot<T*>* Function(AsyncSnapshot<T*>, Object)') isn't a valid override of 'StreamBuilderBase.afterError' ('AsyncSnapshot<T>* Function(AsyncSnapshot<T*>*, Object, StackTrace)').

lib/flutter_data_stream_builder.dart:92:20

   ╷
92 │   AsyncSnapshot<T> afterError(_, Object error) =>
   │                    ^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/flutter_data_stream_builder.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
rxdart^0.23.10.23.10.27.7
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.16.01.17.0
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^0.23.1 on rxdart does not support the stable version 0.24.0.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.1.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

9
likes
70
pub points
56%
popularity

Publisher

verified publisher iconflutterdata.dev

A pragmatic StreamBuilder with sensible defaults

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter, rxdart

More

Packages that depend on flutter_data_stream_builder