flutter_customer_chat 1.1.0 icon indicating copy to clipboard operation
flutter_customer_chat: ^1.1.0 copied to clipboard

Customer chat flutter package

1
likes
80/ 140
pub points
0%
popularity

We analyzed this package 3 hours ago, and awarded it 80 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
10 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://labs.zoe.im/flutter_customer_chat was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 19 out of 103 API elements (18.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform Windows.

Because:

  • package:flutter_customer_chat/flutter_customer_chat.dart that imports:
  • package:flutter_customer_chat/chatview.dart that imports:
  • package:flutter_zoewebview/flutter_zoewebview.dart that imports:
  • package:flutter_zoewebview/src/provider/inappwebview.dart that imports:
  • package:flutter_inappwebview/flutter_inappwebview.dart that declares support for platforms: Android, iOS.

Package does not support platform Linux.

Because:

  • package:flutter_customer_chat/flutter_customer_chat.dart that imports:
  • package:flutter_customer_chat/chatview.dart that imports:
  • package:flutter_zoewebview/flutter_zoewebview.dart that imports:
  • package:flutter_zoewebview/src/provider/inappwebview.dart that imports:
  • package:flutter_inappwebview/flutter_inappwebview.dart that declares support for platforms: Android, iOS.

Package does not support platform macOS.

Because:

  • package:flutter_customer_chat/flutter_customer_chat.dart that imports:
  • package:flutter_customer_chat/chatview.dart that imports:
  • package:flutter_zoewebview/flutter_zoewebview.dart that imports:
  • package:flutter_zoewebview/src/provider/inappwebview.dart that imports:
  • package:flutter_inappwebview/flutter_inappwebview.dart that declares support for platforms: Android, iOS.

Package does not support platform Web.

Because:

  • package:flutter_customer_chat/flutter_customer_chat.dart that imports:
  • package:flutter_customer_chat/chatview.dart that imports:
  • package:flutter_zoewebview/flutter_zoewebview.dart that imports:
  • package:flutter_zoewebview/src/provider/inappwebview.dart that imports:
  • package:flutter_inappwebview/flutter_inappwebview.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform Android.

Because:

  • package:flutter_customer_chat/flutter_customer_chat.dart that imports:
  • package:flutter_customer_chat/chatview.dart that imports:
  • package:flutter_zoewebview/flutter_zoewebview.dart that imports:
  • package:flutter_zoewebview/src/webview.dart that imports:
  • package:flutter_zoewebview/src/provider/officialwebview.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.

Package does not support platform iOS.

Because:

  • package:flutter_customer_chat/flutter_customer_chat.dart that imports:
  • package:flutter_customer_chat/chatview.dart that imports:
  • package:flutter_zoewebview/flutter_zoewebview.dart that imports:
  • package:flutter_zoewebview/src/webview.dart that imports:
  • package:flutter_zoewebview/src/provider/officialwebview.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_android/webview_android_cookie_manager.dart that declares support for platforms: Android.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: This function has a return type of 'ChatProvider', but doesn't end with a return statement.

lib/provider.dart:17:23

   ╷
17 │   static ChatProvider from(String type) {
   │                       ^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/provider.dart

INFO: The declaration '_updateCustomerCode' isn't referenced.

lib/provider/aihecong.dart:93:10

   ╷
93 │   String _updateCustomerCode() {
   │          ^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/provider/aihecong.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_zoewebview^1.1.01.1.01.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.16.01.17.0
flutter_inappwebview-5.7.2+25.7.2+2
flutter_webview_plugin-0.4.00.4.0
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
path-1.8.31.8.3
plugin_platform_interface-2.1.32.1.3
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.4
webview_flutter-2.8.03.0.4
webview_flutter_android-2.10.42.10.4
webview_flutter_platform_interface-1.9.51.9.5
webview_flutter_wkwebview-2.9.52.9.5

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.2.2 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

1
likes
80
pub points
0%
popularity

Publisher

verified publisher iconzoe.im

Customer chat flutter package

Documentation

API reference

License

Icon for licenses.unknown (LICENSE)

Dependencies

flutter, flutter_zoewebview

More

Packages that depend on flutter_customer_chat