flutter_csv_localization 0.3.1
flutter_csv_localization: ^0.3.1 copied to clipboard

Flutter localizations generator from CSV files.

0
likes
50 / 110
pub points
11 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 30 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:flutter_csv_localization/flutter_csv_localization.dart that imports:
  • package:flutter_csv_localization/src/builder.dart that imports:
  • package:dart_style/dart_style.dart that imports:
  • package:dart_style/src/exceptions.dart that imports:
  • package:analyzer/error/error.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/sdk.dart that imports:
  • package:analyzer/dart/ast/visitor.dart that imports:
  • package:analyzer/dart/ast/ast.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/summary2/reference.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/generated/engine.dart that imports:
  • package:analyzer/error/listener.dart that imports:
  • package:analyzer/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/type_system.dart that imports:
  • package:analyzer/src/dart/element/type_schema_elimination.dart that imports:
  • package:analyzer/src/dart/element/type_schema.dart that imports:
  • package:analyzer/src/dart/element/type_visitor.dart that imports:
  • package:analyzer/src/summary2/named_type_builder.dart that imports:
  • package:analyzer/src/dart/ast/extensions.dart that imports:
  • package:analyzer/src/dart/ast/ast.dart that imports:
  • package:analyzer/src/summary2/linked_unit_context.dart that imports:
  • package:analyzer/src/summary2/linked_library_context.dart that imports:
  • package:analyzer/src/summary2/linked_element_factory.dart that imports:
  • package:analyzer/src/summary2/bundle_reader.dart that imports:
  • package:analyzer/src/dart/element/member.dart that imports:
  • package:analyzer/dart/analysis/session.dart that imports:
  • package:analyzer/file_system/file_system.dart that imports:
  • package:watcher/watcher.dart that imports:
  • package:watcher/src/file_watcher/polling.dart that imports:
  • package:watcher/src/stat.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: Unnecessary new keyword.

bin/generate.dart:9:18

  ╷
9 │   final parser = new ArgParser();
  │                  ^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/generate.dart

INFO: DO use curly braces for all flow control structures.

bin/generate.dart:30:5

   ╷
30 │ ┌     throw Exception(
31 │ └         "input google sheet id must be in the form '{document_uid}/{sheet_name}'");
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/generate.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.5.11.6.02.0.0
code_builder^3.2.03.7.03.7.0
csv^4.0.34.1.05.0.0
dart_style^1.2.71.3.142.0.0
http^0.12.00.12.20.13.1
meta^1.1.71.3.01.3.0
recase^2.0.12.0.13.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-20.0.020.0.0
analyzer-1.4.01.4.0
async-2.5.02.5.0
built_collection-5.0.05.0.0
built_value-8.0.48.0.4
charcode-1.2.01.2.0
cli_util-0.3.00.3.0
collection-1.15.01.15.0
convert-3.0.03.0.0
crypto-3.0.13.0.1
file-6.1.06.1.0
fixnum-1.0.01.0.0
glob-2.0.12.0.1
http_parser-3.1.44.0.0
matcher-0.12.100.12.10
package_config-2.0.02.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
pub_semver-2.0.02.0.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^1.5.1` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^4.0.3` on csv does not support the stable version `5.0.0`, that was published 27 days ago.

When csv is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions csv to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.