flutter_credo 0.1.0
flutter_credo: ^0.1.0 copied to clipboard

This library allows for the easy integration of [Credo].

1
likes
60/ 130
pub points
0%
popularity

We analyzed this package on Oct 25, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 197 API elements (3.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:flutter_credo/flutter_credo.dart that imports:
  • package:flutter_credo/src/credo_plugin.dart that imports:
  • package:flutter_credo/src/domain/repositories/credo_sdk_repository.dart that imports:
  • package:flutter_credo/src/data/data_source/remote_datasource.dart that imports:
  • package:flutter_credo/core/network/http_service_requester.dart that imports:
  • package:flutter_credo/core/constant/credo_constants.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/flutter_credo.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/_unused_dart.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dartz^0.9.20.9.20.10.0
dio^4.0.04.0.14.0.1
equatable^2.0.02.0.32.0.3
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
http_parser-4.0.04.0.0
meta-1.7.01.7.0
path-1.8.01.8.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.9.2` on dartz does not support the stable version `0.10.0`.

Try running dart pub upgrade --major-versions dartz to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Package is not null safe

Because:

  • flutter_credo that depends on:
  • dartz that doesn't opt in to null safety
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

1
likes
60
pub points
0%
popularity

Publisher

dart.charlesarchibong.com

This library allows for the easy integration of [Credo].

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

dartz, dio, equatable, flutter

More

Packages that depend on flutter_credo