dev_dependencies: flutter_coverage_badge: ^0.0.1+1
flutter pub get
flutter test --coverage
flutter pub run flutter_coverage_badge
You can install the package from the command line:
$ pub global activate flutter_coverage_badge
The package has the following executables:
Add this to your package's pubspec.yaml file:
dependencies: flutter_coverage_badge: ^0.0.1+1
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Aug 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter
References Flutter, and has no conflicting libraries.
lib/src/collector.dart. (-1 points)
lib/src/collector.dart reported 2 hints:
line 1 col 8: Unused import: 'dart:convert'.
line 8 col 9: The value of the local variable 'script' isn't used.
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
flutter_coverage_badge.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
Package is pre-v0.1 release. (-10 points)
While nothing is inherently wrong with versions of
0.0.*, it might mean that the author is still experimenting with the general direction of the API.
|Dart SDK||>=2.1.0 <3.0.0|