flutter_core_net 0.0.1 copy "flutter_core_net: ^0.0.1" to clipboard
flutter_core_net: ^0.0.1 copied to clipboard

一个flutter核心net插件

0
likes
130/ 160
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

The package description contains too many non-ASCII characters.

The site uses English as its primary language. The content of the description field in your package's pubspec.yaml should primarily contain characters used in English.

Homepage URL doesn't exist.

At the time of the analysis https://github.com/kooflutter/flutter_core_net.git was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: flutter_core_net,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

7 out of 18 API elements (38.9 %) have documentation comments.

Some symbols that are missing documentation: flutter_core_sharepay, flutter_core_sharepay.FlutterCoreSharepay, flutter_core_sharepay.FlutterCoreSharepay.FlutterCoreSharepay, flutter_core_sharepay.FlutterCoreSharepay.getPlatformVersion, flutter_core_sharepay_method_channel.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Android

Because:

  • package:flutter_core_net/flutter_core_sharepay_web.dart that imports:
  • package:flutter_web_plugins/flutter_web_plugins.dart that imports:
  • package:flutter_web_plugins/src/plugin_registry.dart that imports:
  • dart:ui_web
Package not compatible with platform iOS

Because:

  • package:flutter_core_net/flutter_core_sharepay_web.dart that imports:
  • package:flutter_web_plugins/flutter_web_plugins.dart that imports:
  • package:flutter_web_plugins/src/plugin_registry.dart that imports:
  • dart:ui_web
Package not compatible with platform Windows

Because:

  • package:flutter_core_net/flutter_core_sharepay_web.dart that imports:
  • package:flutter_web_plugins/flutter_web_plugins.dart that imports:
  • package:flutter_web_plugins/src/plugin_registry.dart that imports:
  • dart:ui_web
Package not compatible with platform Linux

Because:

  • package:flutter_core_net/flutter_core_sharepay_web.dart that imports:
  • package:flutter_web_plugins/flutter_web_plugins.dart that imports:
  • package:flutter_web_plugins/src/plugin_registry.dart that imports:
  • dart:ui_web
Package not compatible with platform macOS

Because:

  • package:flutter_core_net/flutter_core_sharepay_web.dart that imports:
  • package:flutter_web_plugins/flutter_web_plugins.dart that imports:
  • package:flutter_web_plugins/src/plugin_registry.dart that imports:
  • dart:ui_web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/flutter_core_sharepay.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/flutter_core_sharepay_method_channel.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.