flutter_core 1.0.2
flutter_core: ^1.0.2 copied to clipboard

flutter_core is a package for flutter to create the core module. Core module is a part of Clean Architecture.

0
likes
60/ 130
pub points
76%
popularity

We analyzed this package 2 days ago, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 96 API elements (6.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:flutter_core/flutter_core.dart that imports:
  • package:flutter_core/service_locator_initializer.dart that imports:
  • package:flutter_local_notifications/flutter_local_notifications.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

lib/flutter_core.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/http_client/authorization_interceptor.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dartz^0.9.10.9.20.10.1
data_connection_checker^0.3.40.3.40.3.4
dio^3.0.93.0.104.0.4
firebase_core^0.4.50.4.51.10.2
firebase_messaging^6.0.166.0.1611.2.0
flutterflutter0.0.00.0.0
flutter_local_notifications^1.4.4+21.5.0+19.1.4
get_it^4.0.44.0.47.2.0
json_annotation^3.0.13.1.14.4.0
json_serializable^3.3.03.5.16.1.1
logger^0.9.20.9.41.1.0
path^1.6.41.8.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.031.0.0
analyzer-0.41.22.8.0
args-2.3.02.3.0
async-2.8.22.8.2
build-1.6.22.1.1
build_config-0.4.71.0.0
characters-1.1.01.2.0
charcode-1.3.11.3.1
checked_yaml-1.0.42.0.1
cli_util-0.3.50.3.5
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
dart_style-1.3.122.2.0
file-6.1.26.1.2
firebase-7.3.39.0.2
firebase_core_platform_interface-1.0.44.2.0
firebase_core_web-0.1.1+21.4.0
flutter_local_notifications_platform_interface-1.0.15.0.0
flutter_web_plugins-0.0.00.0.0
glob-2.0.22.0.2
http-0.12.20.13.4
http_parser-3.1.44.0.0
js-0.6.30.6.3
logging-1.0.21.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
package_config-1.9.32.0.2
platform-2.2.13.1.0
plugin_platform_interface-1.0.32.0.2
pub_semver-2.1.02.1.0
pubspec_parse-0.1.81.1.0
quiver-2.1.53.0.1+1
sky_engine-0.0.990.0.99
source_gen-0.9.10+31.2.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
watcher-1.0.11.0.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 9 issues. Showing the first 2:

The constraint `^0.9.1` on dartz does not support the stable version `0.10.0`.

Try running dart pub upgrade --major-versions dartz to update the constraint.

The constraint `^3.0.9` on dio does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

0
likes
60
pub points
76%
popularity

flutter_core is a package for flutter to create the core module. Core module is a part of Clean Architecture.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dartz, data_connection_checker, dio, firebase_core, firebase_messaging, flutter, flutter_local_notifications, get_it, json_annotation, json_serializable, logger, path

More

Packages that depend on flutter_core