flutter_comms 1.1.0 copy "flutter_comms: ^1.1.0" to clipboard
flutter_comms: ^1.1.0 copied to clipboard

Simple communication pattern abstraction on streams, created for communication between logic classes and or widgets.

1.1.0 #

  • Add example of sending one time events from state management to widgets in README (#69)

  • Add common README for packages (#68)

1.0.0 #

  • Move bloc related apis to comms package, add README (#61)

0.0.6+2 #

  • Fix StateSender to only send messages when state is actually emitted

0.0.6 #

  • Fix useMessageListeners onInitialMessage getting called during build (#49)

0.0.5 #

  • Breaking: Change useMessageListeners onInitialMessage and keys to named parameters (#47)

0.0.4+1 #

  • Upgrade comms package

0.0.4 #

  • Add onInitialMessage to ListenerBloc, ListenerCubit, MessageListener and useMessageListener (#43)

0.0.3+2 #

  • Fix MessageListener type parameter (#40)

0.0.3+1 #

  • Fix export of StateSender

0.0.3 #

  • Add StateSender mixin

0.0.2 #

  • Fix useMessageListener

0.0.1+3 #

  • Fix useMessageListener not using type parameter Message

0.0.1+2 #

  • Add export of comms package

0.0.1+1 #

  • Downgrade flutter_hooks to 0.18.2

0.0.1 #

  • Initial release
23
likes
130
pub points
71%
popularity

Publisher

verified publisherleancode.co

Simple communication pattern abstraction on streams, created for communication between logic classes and or widgets.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

comms, flutter, flutter_hooks, logging, meta, nested

More

Packages that depend on flutter_comms