flutter_collapsing_toolbar 1.0.0 copy "flutter_collapsing_toolbar: ^1.0.0" to clipboard
flutter_collapsing_toolbar: ^1.0.0 copied to clipboard

A Flutter package to create a Romantic Collapsing Toolbar. It will be useful for your awesome app.

47
likes
150/ 160
pub points
77%
popularity

We analyzed this package 4 days ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

9 out of 33 API elements (27.3 %) have documentation comments.

Some symbols that are missing documentation: flutter_collapsing_toolbar, flutter_collapsing_toolbar.CollapsingToolbar.actions, flutter_collapsing_toolbar.CollapsingToolbar.animationCurve, flutter_collapsing_toolbar.CollapsingToolbar.collapsedHeight, flutter_collapsing_toolbar.CollapsingToolbar.controller.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

INFO: Using a colon as the separator before a default value is deprecated and will not be supported in language version 3.0 and later.

lib/src/collapsing_toolbar.dart:56:24

   ╷
56 │     this.animationCurve: Curves.easeIn,
   │                        ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/collapsing_toolbar.dart

INFO: Using a colon as the separator before a default value is deprecated and will not be supported in language version 3.0 and later.

lib/src/collapsing_toolbar.dart:64:32

   ╷
64 │     this.featureCollapsedFactor: 0.6,
   │                                ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/collapsing_toolbar.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

47
likes
150
pub points
77%
popularity

Publisher

verified publisherromanticdeveloper.com

A Flutter package to create a Romantic Collapsing Toolbar. It will be useful for your awesome app.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_collapsing_toolbar