flutter_calendar_carousel 2.4.2 copy "flutter_calendar_carousel: ^2.4.2" to clipboard
flutter_calendar_carousel: ^2.4.2 copied to clipboard

Calendar widget for flutter that is swipeable. This widget can help you build customizable calendar with scrollable actions.

432
likes
100/ 140
pub points
98%
popularity

We analyzed this package 2 days ago, and awarded it 100 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

11 out of 157 API elements (7.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: event, event.Event, event.Event.Event, event.Event.date, event.Event.description.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 25 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/classes/event.dart:22:17

   ╷
22 │   bool operator ==(dynamic other) {
   │                 ^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/classes/event.dart

WARNING: This API is available since SDK 2.14.0, but constraints '>=2.12.0 <4.0.0' don't guarantee it.

lib/classes/event.dart:33:30

   ╷
33 │   int get hashCode => Object.hash(date, description, location, title, icon, id);
   │                              ^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/classes/event.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
intl ^0.18.0 0.18.1 0.19.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.18.0` on intl does not support the stable version `0.19.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

432
likes
100
pub points
98%
popularity

Publisher

verified publisherdooboolab.com

Calendar widget for flutter that is swipeable. This widget can help you build customizable calendar with scrollable actions.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, intl

More

Packages that depend on flutter_calendar_carousel