flutter_buffs 0.1.1
flutter_buffs: ^0.1.1 copied to clipboard

A new Flutter package project.

0
likes
50 / 110
pub points
0 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

  • pubspec.yaml doesn't have a homepage entry.
  • pubspec.yaml doesn't have a repository entry.
The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 8 out of 129 API elements (6.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_buffs/flutter_buffs.dart that imports:
  • package:flutter_buffs/widgets/widgets.dart that imports:
  • package:flutter_buffs/widgets/images.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:cached_network_image/src/image_provider/_image_provider_web.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/json_cache_info_repository.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 19 issues. Showing the first 2:

INFO: Name non-constant identifiers using lowerCamelCase.

lib/helper/context.dart:10:16

   ╷
10 │   final String APP_KEY;
   │                ^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/helper/context.dart

INFO: Name non-constant identifiers using lowerCamelCase.

lib/helper/context.dart:11:16

   ╷
11 │   final String HOSTNAME;
   │                ^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/helper/context.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
awesome_dialog^1.1.31.3.21.3.2
cached_network_image^2.2.0+12.5.13.0.0
commons^0.7.8+30.7.8+30.7.8+3
dio^3.0.93.0.104.0.0
dio_http_cache^0.2.80.2.110.2.11
event_bus^1.1.11.1.12.0.0
extended_text^3.0.13.0.15.0.5
flukit^1.0.21.0.21.0.2
flutterflutter0.0.00.0.0
flutter_secure_storage^3.3.33.3.54.1.0
fluttericon^1.0.71.0.72.0.0
graphql_flutter^3.1.03.1.04.0.1
http^0.12.10.12.20.13.1
json_annotation^3.0.13.1.14.0.1
json_serializable^3.3.03.5.14.1.0
like_button^1.0.11.0.42.0.2
meta^1.1.81.3.01.3.0
quiver^2.1.32.1.53.0.1
simple_animations^2.2.02.5.13.0.3
simple_logger^1.7.01.8.0+11.8.0+1
supercharged^1.7.01.12.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.020.0.0
analyzer-0.41.21.4.0
archive-2.0.133.1.2
args-1.6.02.0.0
async-2.5.02.5.0
build-1.6.22.0.0
build_config-0.4.70.4.7
characters-1.1.01.1.0
charcode-1.2.01.2.0
checked_yaml-1.0.42.0.1
cli_util-0.3.00.3.0
clock-1.1.01.1.0
collection-1.15.01.15.0
connectivity-0.4.9+53.0.3
connectivity_for_web-0.3.1+40.4.0
connectivity_macos-0.1.0+70.2.0
connectivity_platform_interface-1.0.62.0.1
convert-2.1.13.0.0
crypto-2.1.53.0.1
dart_style-1.3.122.0.0
data_connection_checker-0.3.40.3.4
date_format-1.0.92.0.2
device_info-0.4.2+102.0.0
device_info_platform_interface-1.0.12.0.1
extended_text_library-3.0.05.0.2
ffi-1.0.01.0.0
file-6.1.06.1.0
flare_dart-2.3.42.3.4
flare_flutter-2.0.63.0.0
flutter_blurhash-0.5.00.6.0
flutter_cache_manager-2.1.23.0.1
flutter_web_plugins-0.0.00.0.0
get_version-0.2.20.2.2
glob-2.0.12.0.1
gql-0.12.40.12.4
graphql-3.1.04.0.1
http_parser-3.1.44.0.0
image-2.1.193.0.2
intl-0.16.10.17.0
js-0.6.30.6.3
logging-1.0.11.0.1
matcher-0.12.100.12.10
mime-0.9.71.0.0
octo_image-0.3.01.0.0+1
oktoast-2.3.23.0.0
package_config-1.9.32.0.0
package_info-0.4.3+42.0.0
path-1.8.01.8.0
path_provider-1.6.282.0.1
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.0
petitparser-3.1.04.1.0
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.2.14.2.1
progress_indicators-0.1.51.0.0
pub_semver-2.0.02.0.0
pubspec_parse-0.1.81.0.0
rxdart-0.24.10.26.0
sa_v1_migration-1.1.21.1.2
share-0.6.5+42.0.1
shared_preferences-0.5.12+42.0.5
shared_preferences_linux-0.0.2+42.0.0
shared_preferences_macos-0.0.1+112.0.0
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.0
shared_preferences_windows-0.0.2+32.0.0
sky_engine-0.0.990.0.99
source_gen-0.9.10+31.0.0
source_span-1.8.11.8.1
sqflite-1.3.2+42.0.0+3
sqflite_common-1.0.3+32.0.0+2
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
supercharged_dart-1.4.02.0.0
synchronized-2.2.0+23.0.0
term_glyph-1.2.01.2.0
time-1.4.12.0.0
typed_data-1.3.01.3.0
url_launcher-5.7.106.0.3
url_launcher_linux-0.0.1+42.0.0
url_launcher_macos-0.0.1+92.0.0
url_launcher_platform_interface-1.0.92.0.2
url_launcher_web-0.1.5+32.0.0
url_launcher_windows-0.0.1+32.0.0
uuid-2.2.23.0.4
uuid_enhanced-3.0.23.0.2
vector_math-2.1.02.1.0
watcher-1.0.01.0.0
websocket-0.0.50.0.5
win32-2.0.52.0.5
xdg_directories-0.1.20.2.0
xml-4.5.15.1.0
yaml-3.1.03.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 14 issues. Showing the first 2:

The constraint `^2.2.0+1` on cached_network_image does not support the stable version `3.0.0`, that was published 16 days ago.

When cached_network_image is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions cached_network_image to update the constraint.

The constraint `^3.0.9` on dio does not support the stable version `4.0.0`, that was published 15 days ago.

When dio is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.