flutter_braintree 3.0.0 copy "flutter_braintree: ^3.0.0" to clipboard
flutter_braintree: ^3.0.0 copied to clipboard

Flutter plugin that wraps the native Braintree SDKs. Enables payments with credit cards, PayPal, Google Pay and more.

180
likes
120/ 140
pub points
96%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

57 out of 91 API elements (62.6 %) have documentation comments.

Some symbols that are missing documentation: flutter_braintree, flutter_braintree.ApplePaySummaryItem, flutter_braintree.ApplePaySummaryItem.ApplePaySummaryItem, flutter_braintree.ApplePaySummaryItemType, flutter_braintree.ApplePaySummaryItemType.ApplePaySummaryItemType.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_braintree/flutter_braintree.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_braintree/flutter_braintree.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:flutter_braintree/flutter_braintree.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flutter_braintree/flutter_braintree.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

WARNING: This API is available since SDK 2.15.0, but constraints '>=2.12.0 <3.0.0' don't guarantee it.

lib/src/request.dart:186:48

    ╷
186 │     'payPalPaymentIntent': payPalPaymentIntent.name,
    │                                                ^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/request.dart

WARNING: This API is available since SDK 2.15.0, but constraints '>=2.12.0 <3.0.0' don't guarantee it.

lib/src/request.dart:187:56

    ╷
187 │     'payPalPaymentUserAction': payPalPaymentUserAction.name,
    │                                                        ^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/request.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
meta >=1.0.0 <2.0.0 1.11.0 1.12.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Flutter 3.19.0, Dart 3.3.0.

Check the analysis log for details.

180
likes
120
pub points
96%
popularity

Publisher

verified publisherbyte-sapling.io

Flutter plugin that wraps the native Braintree SDKs. Enables payments with credit cards, PayPal, Google Pay and more.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, meta

More

Packages that depend on flutter_braintree