flutter_bloc_patterns 0.9.0 icon indicating copy to clipboard operation
flutter_bloc_patterns: ^0.9.0 copied to clipboard

A set of most common BLoC use cases build on top of flutter_bloc library.

5
likes
120/ 130
pub points
45%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 87 out of 146 API elements (59.6 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bloc^7.0.07.2.18.0.3
collection^1.15.01.16.01.16.0
equatable^2.0.32.0.32.0.3
flutterflutter0.0.00.0.0
flutter_bloc^7.0.17.3.38.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.1
material_color_utilities-0.1.40.1.5
meta-1.7.01.8.0
nested-1.0.01.0.0
provider-6.0.36.0.3
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^7.0.0` on bloc does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions bloc to update the constraint.

The constraint `^7.0.1` on flutter_bloc does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions flutter_bloc to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.13, Flutter 3.0.3, Dart 2.17.5.

5
likes
120
pub points
45%
popularity

Publisher

verified publisher iconklisiewicz.dev

A set of most common BLoC use cases build on top of flutter_bloc library.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

bloc, collection, equatable, flutter, flutter_bloc

More

Packages that depend on flutter_bloc_patterns