flutter_bloc 7.0.0-nullsafety.2
flutter_bloc: ^7.0.0-nullsafety.2 copied to clipboard

Flutter Widgets that make it easy to implement the BLoC (Business Logic Component) design pattern. Built to be used with the bloc state management package.

2078
likes
120 / 130
pub points
99 %
popularity

We analyzed this package on Mar 27, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 50 out of 51 API elements (98.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'listen' is deprecated and shouldn't be used. Use stream.listen instead. Will be removed in v8.0.0.

lib/src/bloc_listener.dart:178:27

    ╷
178 │     _subscription = _bloc.listen((state) {
    │                           ^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/bloc_listener.dart

INFO: 'listen' is deprecated and shouldn't be used. Use stream.listen instead. Will be removed in v8.0.0.

lib/src/bloc_provider.dart:139:32

    ╷
139 │     final subscription = value.listen(
    │                                ^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/bloc_provider.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bloc>=7.0.0-nullsafety.2 <7.0.07.0.0-nullsafety.47.0.0
flutterflutter0.0.00.0.0
provider>=5.0.0-nullsafety.3 <5.0.05.0.0-nullsafety.55.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
nested-1.0.01.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=7.0.0-nullsafety.2 <7.0.0` on bloc does not support the stable version `7.0.0`, that was published 9 days ago.

When bloc is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions bloc to update the constraint.

The constraint `>=5.0.0-nullsafety.3 <5.0.0` on provider does not support the stable version `5.0.0`, that was published 23 days ago.

When provider is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions provider to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.15.4, Flutter 2.0.3, Dart 2.12.2.

2078
likes
120
pub points
99%
popularity

Publisher

bloclibrary.dev

Flutter Widgets that make it easy to implement the BLoC (Business Logic Component) design pattern. Built to be used with the bloc state management package.

Homepage
Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

MIT (LICENSE)

Dependencies

bloc, flutter, provider

More

Packages that depend on flutter_bloc