flutter_ble_lib 3.0.0-beta icon indicating copy to clipboard operation
flutter_ble_lib: ^3.0.0-beta copied to clipboard

FlutterBle Library is a flutter library that supports BLE operations. It uses MultiPlatformBleAdapter as a native backend..

112
likes
100/ 130
pub points
89%
popularity

We analyzed this package 9 days ago, and awarded it 100 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 105 out of 220 API elements (47.7 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_ble_lib/flutter_ble_lib.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_ble_lib/flutter_ble_lib.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:flutter_ble_lib/flutter_ble_lib.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flutter_ble_lib/flutter_ble_lib.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because mockito >=4.0.0 <4.1.1+1 depends on test_api ^0.2.1 and mockito >=4.1.1+1 <4.1.2 depends on test_api >=0.2.1 <0.4.0, mockito >=4.0.0 <4.1.2 requires test_api >=0.2.1 <0.4.0.
And because mockito >=4.1.2 <=5.0.0-nullsafety.7 depends on test_api ^0.2.19-nullsafety and every version of flutter_test from sdk depends on test_api 0.4.8, flutter_test from sdk is incompatible[...]
So, because flutter_ble_lib depends on both mockito ^4.0.0 and flutter_test from sdk, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.12, Flutter 2.10.5, Dart 2.16.2.

112
likes
100
pub points
89%
popularity

Publisher

verified publisher iconpolidea.com

FlutterBle Library is a flutter library that supports BLE operations. It uses MultiPlatformBleAdapter as a native backend..

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

async, collection, flutter

More

Packages that depend on flutter_ble_lib