flutter_autocomplete_text_field 0.0.3 icon indicating copy to clipboard operation
flutter_autocomplete_text_field: ^0.0.3 copied to clipboard

Flutter autocomplete text field.

0
likes
95/ 140
pub points
27%
popularity

We analyzed this package 24 hours ago, and awarded it 95 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
15 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

Repository URL is insecure.

Update the repository field and use a secure (https) URL.

Issue tracker URL is insecure.

Update the issue_tracker field and use a secure (https) URL.

0/5 points: Provide a valid README.md

README.md is empty.

The README.md file should inform others about your project, what it does, and how they can use it. See: the example generated by stagehand.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 45 API elements (11.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.16.01.17.0
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.7.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.20, Flutter 3.3.7, Dart 2.18.4.

0
likes
95
pub points
27%
popularity

Publisher

verified publisher iconsvipas.dev

Flutter autocomplete text field.

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_autocomplete_text_field