flutter_auto_gui 0.0.3 copy "flutter_auto_gui: ^0.0.3" to clipboard
flutter_auto_gui: ^0.0.3 copied to clipboard

PlatformWindows

A flutter plugin for desktop applications for controlling mouse and keyboard to automate interactions with other applications.

25
likes
135/ 140
pub points
58%
popularity

We analyzed this package 1 hour ago, and awarded it 135 pub points (of a possible 140):

failed
Follow Dart file conventions
25 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 2 links are insecure.

README.md:2:256

  ╷
2 │ <p>A flutter plugin for desktop applications for controlling mouse and keyboard to automate interactions with other applications. This plugin is highly inspired by the <a href="https://pyautogui.readthedocs.io/en/latest/">PyAutoGui</a> python package and <a href="http://robotjs.io/">RobotJs</a> and as such tries to mimic most of the available methods.</p>
  │                                                                                                                                                                                                                                                                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

15 out of 20 API elements (75.0 %) have documentation comments.

Some symbols that are missing documentation: flutter_auto_gui, flutter_auto_gui.FlutterAutoGUI, flutter_auto_gui.FlutterAutoGUI.FlutterAutoGUI, flutter_auto_gui.MouseButton, flutter_auto_gui.MouseButton.MouseButton.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:flutter_auto_gui/flutter_auto_gui.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:flutter_auto_gui/flutter_auto_gui.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:flutter_auto_gui/flutter_auto_gui.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:flutter_auto_gui/flutter_auto_gui.dart that declares support for platforms: Windows.
Package does not support platform `Web`.

Because:

  • package:flutter_auto_gui/flutter_auto_gui.dart that declares support for platforms: Windows.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_auto_gui_platform_interface ^0.0.3 0.0.3 0.0.3
flutter_auto_gui_windows ^0.0.3 0.0.3 0.0.3
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

25
likes
135
pub points
58%
popularity

Publisher

verified publisherchappie.dev

A flutter plugin for desktop applications for controlling mouse and keyboard to automate interactions with other applications.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_auto_gui_platform_interface, flutter_auto_gui_windows, plugin_platform_interface

More

Packages that depend on flutter_auto_gui