flutter_apple_pay 0.1.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 81

flutter_google_pay #

pub

Accept Payments with Apple Pay.

Usage #

    import 'package:flutter_apple_pay/flutter_apple_pay.dart';
  
  
    Future<void> makePayment() async {
       dynamic platformVersion;
       PaymentItem paymentItems = PaymentItem(label: 'Label', amount: 51.0);
       try {
         platformVersion = await FlutterApplePay.makePayment(
           countryCode: "US",
           currencyCode: "USD",
           paymentNetworks: [PaymentNetwork.visa, PaymentNetwork.mastercard],
           merchantIdentifier: "merchant.stripeApplePayTest",
           paymentItems: [paymentItems],
         );
         print(platformVersion);
       } on PlatformException {
         platformVersion = 'Failed to get platform version.';
       }
     }

0.1.3 #

  • Fix stripe token

0.1.2+2 #

  • Docs

0.0.1 #

  • TODO: Describe initial release.

example/lib/main.dart

import 'dart:async';

import 'package:flutter/material.dart';
import 'package:flutter/services.dart';
import 'package:flutter_apple_pay/flutter_apple_pay.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  @override
  void initState() {
    super.initState();
  }

  Future<void> makePayment() async {
    dynamic platformVersion;
    PaymentItem paymentItems = PaymentItem(label: 'Label', amount: 51.0);
    try {
      platformVersion = await FlutterApplePay.makePayment(
        countryCode: "US",
        currencyCode: "USD",
        paymentNetworks: [PaymentNetwork.visa, PaymentNetwork.mastercard],
        merchantIdentifier: "merchant.stripeApplePayTest",
        paymentItems: [paymentItems],
        stripePublishedKey: "pk_test_TYooMQauvdEDq54NiTphI7jx"
      );
      print(platformVersion);
    } on PlatformException {
      platformVersion = 'Failed to get platform version.';
    }
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Apple Pay Test'),
        ),
        body: Center(
          child:
          Column(
            mainAxisAlignment: MainAxisAlignment.center,
            children: <Widget>[
                Text('Waiting for Apple Pay modal.'),
                RaisedButton(
                  child: Text('Call payment'),
                  onPressed: () => makePayment(),
                )
            ],
          )
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_apple_pay: ^0.1.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_apple_pay/flutter_apple_pay.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
68
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
88
Overall:
Weighted score of the above. [more]
81
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:flutter_apple_pay/flutter_apple_pay.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:flutter_apple_pay/flutter_apple_pay.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:flutter_apple_pay/flutter_apple_pay.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:flutter_apple_pay/flutter_apple_pay.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [flutter_apple_pay] that is in a package requiring null.

Maintenance suggestions

Package is getting outdated. (-11.78 points)

The package was last published 58 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8