flutter_apm 6.3.0 icon indicating copy to clipboard operation
flutter_apm: ^6.3.0 copied to clipboard

Build, drive and manage your multi-dimensional customer engagement program.

example/lib/main.dart

// Copyright 2018 The Flutter team. All rights reserved.
// Use of this source code is governed by a BSD-style license that can be
// found in the LICENSE file.

import 'package:flutter/material.dart';
import 'package:flutter_apm_example/screens/first_screen.dart';
import 'package:flutter_apm_example/utils/apm_utils.dart';
import 'package:flutter_apm/apm_navigator_observer.dart';

void main() {
  return runApp(MyApp());
}

APMNavigatorObserver<PageRoute> apmObserver = APMNavigatorObserver<PageRoute>();

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    APMUtils.initSDKAPM();
    APMUtils.updateUserPropertiesAPM();
    return MaterialApp(
      title: 'Demo',
      home: FirstScreen(),
      navigatorObservers: [apmObserver],
    );
  }
}
1
likes
120
pub points
12%
popularity

Publisher

unverified uploader

Build, drive and manage your multi-dimensional customer engagement program.

Homepage

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_apm