flutter_aepedgeconsent 3.0.0 copy "flutter_aepedgeconsent: ^3.0.0" to clipboard
flutter_aepedgeconsent: ^3.0.0 copied to clipboard

Official Adobe Experience Platform support for Flutter apps. The AEP Consent Collection plugin enables consent preferences collection from your Flutter app when using the Adobe Experience Platform Mob [...]

0
likes
120/ 140
pub points
89%
popularity

We analyzed this package 7 hours ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too long.

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

4 out of 5 API elements (80.0 %) have documentation comments.

Some symbols that are missing documentation: flutter_aepedgeconsent.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_aepedgeconsent/flutter_aepedgeconsent.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_aepedgeconsent/flutter_aepedgeconsent.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:flutter_aepedgeconsent/flutter_aepedgeconsent.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flutter_aepedgeconsent/flutter_aepedgeconsent.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_aepcore >=3.0.0 <4.0.0 3.0.0 3.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Flutter 3.20.0-1.1.pre, Dart 3.4.0-99.0.dev.

Check the analysis log for details.

0
likes
120
pub points
89%
popularity

Publisher

verified publisheradobe.com

Official Adobe Experience Platform support for Flutter apps. The AEP Consent Collection plugin enables consent preferences collection from your Flutter app when using the Adobe Experience Platform Mobile SDK and the Edge Network extension.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter, flutter_aepcore

More

Packages that depend on flutter_aepedgeconsent