flutter_advanced_networkimage 0.7.0
flutter_advanced_networkimage: ^0.7.0 copied to clipboard

Flutter Android iOS

An advanced image provider provides caching and retrying for flutter app. Now with zoomable widget and transition to image widget.

106
likes
80 / 110
pub points
96 %
popularity

We analyzed this package on Jan 23, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 123 out of 163 API elements (75.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_advanced_networkimage/provider.dart that imports:
  • package:flutter_advanced_networkimage/src/provider/flutter_advanced_networksvg.dart that imports:
  • package:flutter_advanced_networkimage/src/utils.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: The member 'resolve' is declared non-virtual in 'ImageProvider' and can't be overridden in subclasses.

lib/src/provider/flutter_advanced_networkimage.dart:137:15

    ╷
137 │   ImageStream resolve(ImageConfiguration configuration) {
    │               ^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/provider/flutter_advanced_networkimage.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutter_svg^0.17.10.17.40.19.2+1
http^0.12.00.12.20.12.2
path^1.6.41.7.01.8.0-nullsafety.3
path_provider^1.6.01.6.271.6.27
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
ffi-0.1.30.1.3
file-5.2.15.2.1
http_parser-3.1.43.1.4
intl-0.16.10.16.1
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path_drawing-0.4.1+10.4.1+1
path_parsing-0.1.40.1.4
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+80.0.4+8
path_provider_platform_interface-1.0.41.0.4
path_provider_windows-0.0.4+30.0.4+3
pedantic-1.9.21.10.0-nullsafety.3
petitparser-3.1.03.1.0
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
source_span-1.7.01.8.0-nullsafety.4
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
win32-1.7.41.7.4
xdg_directories-0.1.20.1.2
xml-3.7.04.5.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.17.1` on flutter_svg does not support the latest published version `0.19.2+1`

pubspec.yaml:12:16

   ╷
12 │   flutter_svg: ^0.17.1
   │                ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

106
likes
80
pub points
96%
popularity

An advanced image provider provides caching and retrying for flutter app. Now with zoomable widget and transition to image widget.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

fnatic.roach@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, flutter_svg, http, path, path_provider

More

Packages that depend on flutter_advanced_networkimage