flutter_adaptive_cards 0.1.2
flutter_adaptive_cards: ^0.1.2 copied to clipboard

Adaptive Cards are platform-agnostic snippets of UI, authored in JSON, that apps and services can openly exchange.

8
likes
80/ 130
pub points
67%
popularity

We analyzed this package on Oct 20, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/neohelden/Flutter-AdaptiveCards was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 18 out of 88 API elements (20.5 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:flutter_adaptive_cards/flutter_adaptive_cards.dart that imports:
  • package:flutter_adaptive_cards/src/flutter_adaptive_cards.dart that imports:
  • package:flutter_adaptive_cards/src/registry.dart that imports:
  • package:flutter_adaptive_cards/src/elements/media.dart that imports:
  • package:video_player/video_player.dart that declares support for platforms: Android, iOS, Web.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 28 issues. Showing the first 2:

lib/flutter_adaptive_cards.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/action_handler.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because every version of flutter_test from sdk depends on test_api 0.4.2 and mockito >=4.1.2 <=5.0.0-nullsafety.7 depends on test_api ^0.2.19-nullsafety, flutter_test from sdk is incompatible wit[...]
So, because flutter_adaptive_cards depends on both flutter_test any from sdk and mockito ^4.1.3, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

8
likes
80
pub points
67%
popularity

Publisher

neohelden.com

Adaptive Cards are platform-agnostic snippets of UI, authored in JSON, that apps and services can openly exchange.

Repository (missing)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

chewie, flutter, flutter_markdown, http, intl, provider, tinycolor, uuid, video_player

More

Packages that depend on flutter_adaptive_cards