fluro_annotation_generator_fork 1.0.0
fluro_annotation_generator_fork: ^1.0.0 copied to clipboard

Enable annotation support for fluro fork, which automatically generate fluro routes for you.

1
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 9 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Don't import implementation files from another package.

lib/src/annotation/f_route.dart:1:8

  ╷
1 │ import 'package:fluro_fork/src/common.dart'
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/annotation/f_route.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.39.80.39.171.4.0
build^1.2.21.6.22.0.0
build_config^0.4.20.4.70.4.7
fluro_fork^0.0.10.0.10.0.1
flutterflutter0.0.00.0.0
glob^1.2.01.2.02.0.1
source_gen^0.9.50.9.10+21.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.020.0.0
args-1.6.02.0.0
async-2.5.02.5.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
checked_yaml-1.0.42.0.1
cli_util-0.2.00.3.0
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
csslib-0.16.20.17.0
dart_style-1.3.62.0.0
file-5.2.16.1.0
html-0.14.0+40.15.0
intl-0.17.00.17.0
js-0.6.30.6.3
json_annotation-4.0.14.0.1
logging-1.0.11.0.1
meta-1.3.01.3.0
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pub_semver-1.4.42.0.0
pubspec_parse-0.1.81.0.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.39.8` on analyzer does not support the stable version `0.40.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.2.2` on build does not support the stable version `2.0.0`, that was published 26 days ago.

When build is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

1
likes
70
pub points
0%
popularity

Enable annotation support for fluro fork, which automatically generate fluro routes for you.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

brian.ja.schardt@gmail.com

License

MIT (LICENSE)

Dependencies

analyzer, build, build_config, fluro_fork, flutter, glob, source_gen

More

Packages that depend on fluro_annotation_generator_fork