fluidcoins 0.2.0 copy "fluidcoins: ^0.2.0" to clipboard
fluidcoins: ^0.2.0 copied to clipboard

Accept 10+ cryptocurrencies from customers anywhere in the world using FluidCoins.

6
likes
140/ 160
pub points
23%
popularity

We analyzed this package 28 hours ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: GPL-3.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

14 out of 28 API elements (50.0 %) have documentation comments.

Some symbols that are missing documentation: fluidcoins, fluidcoins.FluidResponse, fluidcoins.FluidResponse.FluidResponse, fluidcoins.FluidResponse.amount, fluidcoins.FluidResponse.coin.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:fluidcoins/fluidcoins.dart that imports:
  • package:fluidcoins/src/views/fluidcoins_widget.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:fluidcoins/fluidcoins.dart that imports:
  • package:fluidcoins/src/views/fluidcoins_widget.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:fluidcoins/fluidcoins.dart that imports:
  • package:fluidcoins/src/views/fluidcoins_widget.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:fluidcoins/fluidcoins.dart that imports:
  • package:fluidcoins/src/views/fluidcoins_widget.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:fluidcoins/fluidcoins.dart that imports:
  • package:fluidcoins/src/views/fluidcoins_widget.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:fluidcoins/fluidcoins.dart that imports:
  • package:fluidcoins/src/views/fluidcoins_widget.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_android/webview_surface_android.dart that declares support for platforms: Android.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

INFO: The import of 'package:flutter/cupertino.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/material.dart'.

lib/src/fluidcoins.dart:3:8

  ╷
3 │ import 'package:flutter/cupertino.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/fluidcoins.dart

INFO: Using a colon as the separator before a default value is deprecated and will not be supported in language version 3.0 and later.

lib/src/fluidcoins.dart:21:16

   ╷
21 │     String name: '',
   │                ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/fluidcoins.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
webview_flutter ^3.0.0 3.0.4 4.8.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
webview_flutter_android - 2.10.4 3.16.4
webview_flutter_platform_interface - 1.9.5 2.10.0
webview_flutter_wkwebview - 2.9.5 3.14.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.0` on webview_flutter does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions webview_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

6
likes
140
pub points
23%
popularity

Publisher

verified publisherdjade.net

Accept 10+ cryptocurrencies from customers anywhere in the world using FluidCoins.

Repository (GitHub)
View/report issues

Documentation

API reference

License

GPL-3.0 (license)

Dependencies

flutter, webview_flutter

More

Packages that depend on fluidcoins