flightmap_gl_web 0.7.0
flightmap_gl_web: ^0.7.0 copied to clipboard

Web platform implementation of mapbox_gl

0
likes
40/ 130
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 40 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/karanveer0802/flightmapfluttersdk was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 127 API elements (3.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 7 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Android`.

Because:

  • package:flightmap_gl_web/flightmap_gl_web.dart that declares support for platforms: Web.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/src/feature_manager/feature_manager.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/feature_manager/symbol_manager.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flightmap_gl_platform_interface^0.7.00.7.00.7.0
flutterflutter0.0.00.0.0
flutter_web_pluginsflutter0.0.00.0.0
image^2.1.122.1.193.1.0
mapbox_gl_dart^0.1.50.1.50.2.1
meta^1.1.71.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.6
args-1.6.02.3.0
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
js-0.6.30.6.3
path-1.8.01.8.0
petitparser-3.1.04.4.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
xml-4.5.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.1.12` on image does not support the stable version `3.0.1`.

Try running dart pub upgrade --major-versions image to update the constraint.

The constraint `^0.1.5` on mapbox_gl_dart does not support the stable version `0.2.0`, that was published 26 days ago.

When mapbox_gl_dart is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions mapbox_gl_dart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.