fledge 0.1.3
fledge: ^0.1.3

Dart native
Flutter Android iOS

CICD for Flutter. Automates build, testing and signing on a number of supported build servers. Automates upload to Google and Apple stores for beta testing and full release.

5
likes
90 / 110
pub points
32 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 25 out of 40 API elements (62.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:fledge/fledge.dart that imports:
  • package:fledge/src/commands/release.dart that imports:
  • package:fledge/src/log.dart that imports:
  • package:fledge/src/utils.dart that imports:
  • package:fledge/src/io.dart that imports:
  • package:fledge/src/exceptions.dart that imports:
  • dart:isolate
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

INFO: DO use curly braces for all flow control structures.

lib/src/commands/beta.dart:95:7

   ╷
95 │ ┌       errorMessage =
96 │ └           'Error: must be in dev branch and all files committed and pushed';
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/commands/beta.dart

INFO: DO use curly braces for all flow control structures.

lib/src/commands/beta.dart:103:7

    ╷
103 │       errorMessage = 'Error: all dev files must be pushed';
    │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/commands/beta.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.4.11.6.01.6.0
async^2.0.02.4.22.4.2
crypto>=1.0.0 <3.0.02.1.52.1.5
http^0.12.00.12.20.12.2
http_multi_server>=1.0.0 <3.0.02.2.02.2.0
meta^1.1.01.2.41.2.4
path^1.2.01.7.01.7.0
pool^1.0.01.4.01.4.0
pub_semver^1.4.01.4.41.4.4
resource^2.1.52.1.72.1.7
source_span^1.4.01.7.01.7.0
stack_trace^1.0.01.9.61.9.6
yaml^2.0.02.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
http_parser-3.1.43.1.4
pedantic-1.9.21.9.2
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

5
likes
90
pub points
32%
popularity

CICD for Flutter. Automates build, testing and signing on a number of supported build servers. Automates upload to Google and Apple stores for beta testing and full release.

Homepage

Documentation

API reference

Uploader

mmcc007@gmail.com

License

MIT (LICENSE.txt)

Dependencies

args, async, crypto, http, http_multi_server, meta, path, pool, pub_semver, resource, source_span, stack_trace, yaml

More

Packages that depend on fledge