flattery 0.3.0
flattery: ^0.3.0 copied to clipboard

Flattery is a library for building HTML elements using Widgets.

0
likes
90/ 130
pub points
0%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/flattery_example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 45 out of 72 API elements (62.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:flattery/flattery.dart that imports:
  • package:flattery/src/widget.dart that imports:
  • dart:html
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/widgets/checkbox.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.4.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.

0
likes
90
pub points
0%
popularity

Flattery is a library for building HTML elements using Widgets.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

More

Packages that depend on flattery