flatter 0.4.0 copy "flatter: ^0.4.0" to clipboard
flatter: ^0.4.0 copied to clipboard

We make Flutter flat, We are Flatter. Flatter is an extra-light and powerful solution for the hell of nested widgets in Flutter. Flatter makes Flutter widgets flat and readable.

14
likes
90/ 140
pub points
12%
popularity

We analyzed this package 4 days ago, and awarded it 90 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

138 out of 381 API elements (36.2 %) have documentation comments.

Some symbols that are missing documentation: flatter, flatter.AlignExt, flatter.AlignExt.alignAtBottomRight, flatter.AlignModifier.alignment, flatter.AlignModifier.body.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 22 issues. Showing the first 2:

ERROR: The argument type 'BorderRadius?' can't be assigned to the parameter type 'BorderRadiusGeometry'.

lib/src/modifier/clip_rect_modifier.dart:20:21

   ╷
20 │       borderRadius: borderRadius,
   │                     ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/modifier/clip_rect_modifier.dart

INFO: 'WindowPadding' is deprecated and shouldn't be used. Use ViewPadding instead. This feature was deprecated after v3.8.0-14.0.pre.

lib/flatter.dart:3:29

  ╷
3 │ import 'dart:ui' as ui show WindowPadding;
  │                             ^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/flatter.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

14
likes
90
pub points
12%
popularity

Publisher

unverified uploader

We make Flutter flat, We are Flatter. Flatter is an extra-light and powerful solution for the hell of nested widgets in Flutter. Flatter makes Flutter widgets flat and readable.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on flatter