flattener 0.0.1+4 icon indicating copy to clipboard operation
flattener: ^0.0.1+4 copied to clipboard

Flatten and unflatten maps easily using this package. It exposes two methods with the names described previously. Currently only maps of type Map<String, dynamic> are supported.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add flattener

With Flutter:

 $ flutter pub add flattener

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  flattener: ^0.0.1+4

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:flattener/flattener.dart';
1
likes
90
pub points
0%
popularity

Publisher

unverified uploader

Flatten and unflatten maps easily using this package. It exposes two methods with the names described previously. Currently only maps of type Map<String, dynamic> are supported.

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

More

Packages that depend on flattener