flappy_search_bar_fork 1.7.4
flappy_search_bar_fork: ^1.7.4 copied to clipboard

A SearchBar widget automatizing most of your asynchronous searchs cases.

11
likes
90 / 130
pub points
75 %
popularity

We analyzed this package on Jul 23, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 36 out of 62 API elements (58.1 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/flappy_search_bar.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/search_bar_style.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
async^2.2.02.8.12.8.1
flutterflutter0.0.00.0.0
flutter_staggered_grid_view^0.3.00.3.40.4.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.3.0` on flutter_staggered_grid_view does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions flutter_staggered_grid_view to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.

11
likes
90
pub points
75%
popularity

A SearchBar widget automatizing most of your asynchronous searchs cases.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

async, flutter, flutter_staggered_grid_view

More

Packages that depend on flappy_search_bar_fork