flamingo_generator 0.9.0-nullsafety.2
flamingo_generator: ^0.9.0-nullsafety.2 copied to clipboard

Automatically generate code for converting flamingo JSON by annotating Dart classes.

1
likes
70 / 130
pub points
48 %
popularity

We analyzed this package on Mar 27, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:flamingo_generator/flamingo_generator.dart that imports:
  • package:flamingo_generator/src/field_value_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: The library 'package:build/build.dart' is legacy, and should not be imported into a null safe library.

lib/flamingo_generator.dart:1:8

  ╷
1 │ import 'package:build/build.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/flamingo_generator.dart

INFO: The library 'package:source_gen/source_gen.dart' is legacy, and should not be imported into a null safe library.

lib/flamingo_generator.dart:2:8

  ╷
2 │ import 'package:source_gen/source_gen.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/flamingo_generator.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.41.0 <1.0.00.41.21.3.0
build>=1.6.0 <2.0.01.6.22.0.0
flamingo_annotation^0.5.0-nullsafety.00.5.00.5.0
meta^1.3.0-nullsafety.61.3.01.3.0
source_gen^0.9.00.9.10+31.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.019.0.0
args-2.0.02.0.0
async-2.5.02.5.0
charcode-1.2.01.2.0
cli_util-0.3.00.3.0
collection-1.15.01.15.0
convert-3.0.03.0.0
crypto-3.0.03.0.0
dart_style-1.3.122.0.0
file-6.1.06.1.0
glob-2.0.12.0.1
logging-1.0.11.0.1
package_config-1.9.32.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
pub_semver-2.0.02.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `>=0.41.0 <1.0.0` on analyzer does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `>=1.6.0 <2.0.0` on build does not support the stable version `2.0.0`, that was published 15 days ago.

When build is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Package is not null safe

Because:

  • flamingo_generator that depends on:
  • source_gen that doesn't opt in to null safety
For more information

Try running pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.15.4, Dart 2.12.1.

1
likes
70
pub points
48%
popularity

Publisher

neverjp.com

Automatically generate code for converting flamingo JSON by annotating Dart classes.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, build, flamingo_annotation, meta, source_gen

More

Packages that depend on flamingo_generator