flamingo_generator 0.3.4
flamingo_generator: ^0.3.4 copied to clipboard

Automatically generate code for converting flamingo JSON by annotating Dart classes.

1
likes
60/ 120
pub points
43%
popularity

We analyzed this package 8 days ago, and awarded it 60 pub points (of a possible 120):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/hukusuke1007/flamingop was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 10

10/10 points: Package has an example

  • Found example at: example/lib/main.dart
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package not compatible with runtime flutter-native on Android

Because:

  • package:flamingo_generator/flamingo_generator.dart that imports:
  • package:flamingo_generator/src/field_value_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.39.40.39.172.7.0
build>=0.12.6 <2.0.01.6.22.1.1
code_builder^3.4.03.7.04.1.0
flamingo_annotation^0.3.00.3.00.5.0
flutterflutter0.0.00.0.0
meta^1.1.01.7.01.7.0
source_gen^0.9.00.9.10+21.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.030.0.0
args-1.6.02.3.0
async-2.8.22.8.2
built_collection-5.1.15.1.1
built_value-8.1.38.1.3
characters-1.1.01.2.0
charcode-1.3.11.3.1
cli_util-0.2.00.3.5
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
csslib-0.16.20.17.1
dart_style-1.3.62.2.0
file-5.2.16.1.2
fixnum-1.0.01.0.0
glob-1.2.02.0.2
html-0.14.0+40.15.0
intl-0.17.00.17.0
js-0.6.30.6.3
logging-1.0.21.0.2
matcher-0.12.110.12.11
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
package_config-1.9.32.0.2
path-1.8.01.8.0
pedantic-1.11.11.11.1
pub_semver-1.4.42.1.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
watcher-0.9.7+151.0.1
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^0.39.4` on analyzer does not support the stable version `0.40.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `>=0.12.6 <2.0.0` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

1
likes
60
pub points
43%
popularity

Publisher

neverjp.com

Automatically generate code for converting flamingo JSON by annotating Dart classes.

Homepage (missing)
Repository (GitHub)
View/report issues

License

MIT (LICENSE)

Dependencies

analyzer, build, code_builder, flamingo_annotation, flutter, meta, source_gen

More

Packages that depend on flamingo_generator