flame_bloc 1.11.0 copy "flame_bloc: ^1.11.0" to clipboard
flame_bloc: ^1.11.0 copied to clipboard

Integration for the Bloc state management library to Flame games.

40
likes
140/ 140
pub points
90%
popularity

We analyzed this package 20 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

214 out of 251 API elements (85.3 %) have documentation comments.

Some symbols that are missing documentation: flame_bloc, flame_bloc.FlameBlocListenable.handleLifecycleEventAdd, flame_bloc.FlameBlocListenable.handleLifecycleEventMove, flame_bloc.FlameBlocListenable.handleLifecycleEventRemove, flame_bloc.FlameBlocListenable.handleResize.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
bloc ^8.1.1 8.1.3 8.1.3
flame ^1.16.0 1.16.0 1.16.0
flutter flutter 0.0.0 0.0.0
flutter_bloc ^8.1.2 8.1.4 8.1.4
meta ^1.9.1 1.11.0 1.12.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
nested - 1.0.0 1.0.0
ordered_set - 5.0.2 5.0.2
provider - 6.1.1 6.1.1
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Flutter 3.19.0, Dart 3.3.0.

Check the analysis log for details.

40
likes
140
pub points
90%
popularity

Publisher

verified publisherflame-engine.org

Integration for the Bloc state management library to Flame games.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

Funding

Consider supporting this project:

opencollective.com
github.com
patreon.com

License

MIT (LICENSE)

Dependencies

bloc, flame, flutter, flutter_bloc, meta

More

Packages that depend on flame_bloc