fit_kit 0.0.4

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 86

FitKit #

pub package

Flutter plugin for reading health and fitness data. Wraps HealthKit on iOS and GoogleFit on Android. Currently only supports reading heart rate, step count, height and weight.

Usage #

To use this plugin, add fit_kit as a dependency in your pubspec.yaml file.

Getting Started #

Android #

Enable Fitness API and obtain an OAuth 2.0 client ID.

iOS #

Enable HealthKit and add NSHealthShareUsageDescription key to the Info.plist file.

Sample Usage #

If you're using more than one DataType it's advised to call requestPermissions before, otherwise iOS HealthKit will ask to approve every permission one by one in separate screens.

import 'package:fit_kit/fit_kit.dart';

void read() async {
    final results = await FitKit.read(
        DataType.HEART_RATE,
        DateTime.now().subtract(Duration(days: 5)),
        DateTime.now(),
    );
}

void readAll() async {
    if (await FitKit.requestPermissions(DataType.values)) {
      for (DataType type in DataType.values) {
        final results = await FitKit.read(
          type,
          DateTime.now().subtract(Duration(days: 5)),
          DateTime.now(),
        );
      }
    }
}

0.0.4 #

  • BREAKING CHANGE Migrated to use AndroidX.

0.0.3 #

  • Added requestPermissions method to ease requesting more than 1 data type.

0.0.2 #

  • Fix multiple addActivityResultListener issue.

0.0.1 #

  • Initial release.

example/README.md

fit_kit_example #

Demonstrates how to use the fit_kit plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fit_kit: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fit_kit/fit_kit.dart';
  
Version Uploaded Documentation Archive
0.0.4 Apr 15, 2019 Go to the documentation of fit_kit 0.0.4 Download fit_kit 0.0.4 archive
0.0.3 Mar 21, 2019 Go to the documentation of fit_kit 0.0.3 Download fit_kit 0.0.3 archive
0.0.2 Mar 16, 2019 Go to the documentation of fit_kit 0.0.2 Download fit_kit 0.0.2 archive
0.0.1 Mar 12, 2019 Go to the documentation of fit_kit 0.0.1 Download fit_kit 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
78
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
85
Overall:
Weighted score of the above. [more]
86
Learn more about scoring.

We analyzed this package on Jun 26, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

17 out of 17 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test