firestore_serializable 0.0.20 copy "firestore_serializable: ^0.0.20" to clipboard
firestore_serializable: ^0.0.20 copied to clipboard

(still experimental) Generate fromMap(), fromSnapshot() and toMap() methods for your Firestore data models using this library. Based on source_gen, similar to json_serializable

4
likes
20/ 140
pub points
10%
popularity

We analyzed this package 20 hours ago, and awarded it 20 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: firestore_serializable,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: firestore_serializable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run dart pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running dart pub outdated failed with the following output:
The lower bound of "sdk: '>=2.6.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.4.1. Cannot run `dart pub outdated`.

pubspec.yaml:6:8

  ╷
6 │   sdk: '>=2.6.0 <3.0.0'
  │        ^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.4.1.

pubspec.yaml:6:8

  ╷
6 │   sdk: '>=2.6.0 <3.0.0'
  │        ^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

Analyzed with Pana 0.22.3, Dart 3.4.1.

Check the analysis log for details.

4
likes
20
pub points
10%
popularity

Publisher

verified publisherdartlang.rocks

(still experimental) Generate fromMap(), fromSnapshot() and toMap() methods for your Firestore data models using this library. Based on source_gen, similar to json_serializable

Homepage

License

BSD-2-Clause (LICENSE)

Dependencies

analyzer, build, firestore_annotations, source_gen

More

Packages that depend on firestore_serializable