firestore_annotations 0.0.3 copy "firestore_annotations: ^0.0.3" to clipboard
firestore_annotations: ^0.0.3 copied to clipboard

Annotations for the firestore serializable package, which generates fromMap(), fromSnapshot() and toMap() methods for your Firestore data models. Based on source_gen, similar to json_serializable (jso [...]

1
likes
30/ 140
pub points
2%
popularity

We analyzed this package 18 hours ago, and awarded it 30 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too long.

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run dart pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running dart pub outdated failed with the following output:
The lower bound of "sdk: '>=2.1.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.4.1. Cannot run `dart pub outdated`.

pubspec.yaml:7:8

  ╷
7 │   sdk: '>=2.1.0 <3.0.0'
  │        ^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.4.1.

pubspec.yaml:7:8

  ╷
7 │   sdk: '>=2.1.0 <3.0.0'
  │        ^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

Analyzed with Pana 0.22.3, Dart 3.4.1.

Check the analysis log for details.

1
likes
30
pub points
2%
popularity

Publisher

verified publisherdartlang.rocks

Annotations for the firestore serializable package, which generates fromMap(), fromSnapshot() and toMap() methods for your Firestore data models. Based on source_gen, similar to json_serializable (jsoon_annotations)

Repository

License

BSD-2-Clause (LICENSE)

More

Packages that depend on firestore_annotations