firestore_all 0.2.0
firestore_all: ^0.2.0 copied to clipboard

Plugin that wraps Firestore from `firebase` and `cloud_firestore` packages and expose them as a single API.

1
likes
90 / 130
pub points
40 %
popularity

We analyzed this package on Jun 18, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 73 API elements (5.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 4 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:firestore_all/firestore_all.dart that imports:
  • package:firestore_all/src/firestore_mobile.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore>=0.12.0 <0.13.00.12.112.2.2
firebase>=5.0.0 <5.1.05.0.49.0.1
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
firebase_core-0.4.2+21.3.0
firebase_core_platform_interface-1.0.44.0.1
http-0.12.20.13.3
http_parser-3.1.44.0.0
js-0.6.30.6.3
matcher-0.12.100.12.10
meta-1.3.01.4.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
plugin_platform_interface-1.0.32.0.0
quiver-2.1.53.0.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.12.0 <0.13.0` on cloud_firestore does not support the stable version `0.13.0+1`.

Try running dart pub upgrade --major-versions cloud_firestore to update the constraint.

The constraint `>=5.0.0 <5.1.0` on firebase does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions firebase to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Flutter 2.2.2, Dart 2.13.3.

1
likes
90
pub points
40%
popularity

Publisher

Unknown

Plugin that wraps Firestore from `firebase` and `cloud_firestore` packages and expose them as a single API.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

cloud_firestore, firebase, flutter

More

Packages that depend on firestore_all