fireflutter_in_app_purchase 0.0.2 icon indicating copy to clipboard operation
fireflutter_in_app_purchase: ^0.0.2 copied to clipboard

FireFlutter in-app-purchase package. This package is a submodule of fireflutter.

1
likes
90/ 130
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 90 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 29 out of 97 API elements (29.9 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:fireflutter_in_app_purchase/fireflutter_in_app_purchase.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:fireflutter_in_app_purchase/fireflutter_in_app_purchase.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `macOS`.

Because:

  • package:fireflutter_in_app_purchase/fireflutter_in_app_purchase.dart that imports:
  • package:in_app_purchase/in_app_purchase.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:fireflutter_in_app_purchase/fireflutter_in_app_purchase.dart that imports:
  • package:in_app_purchase/in_app_purchase.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore^0.14.40.14.43.1.18
firebase_auth^0.18.4+10.18.4+13.3.20
flutterflutter0.0.00.0.0
in_app_purchase^0.3.4+160.3.5+13.0.6
rxdart^0.24.10.24.10.27.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.9.02.9.0
characters-1.2.01.2.1
charcode-1.3.11.3.1
cloud_firestore_platform_interface-2.2.15.5.8
cloud_firestore_web-0.2.1+22.6.17
collection-1.16.01.16.0
firebase_auth_platform_interface-2.1.46.2.8
firebase_auth_web-0.3.2+33.3.17
firebase_core-0.5.31.18.0
firebase_core_platform_interface-2.1.04.4.1
firebase_core_web-0.2.1+11.6.5
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.44.0.1
intl-0.16.10.17.0
js-0.6.40.6.4
json_annotation-3.1.14.5.0
matcher-0.12.120.12.12
material_color_utilities-0.1.40.1.5
meta-1.7.01.8.0
path-1.8.21.8.2
plugin_platform_interface-1.0.32.1.2
quiver-2.1.53.1.0
sky_engine-0.0.990.0.99
source_span-1.9.01.9.0
stack_trace-1.10.01.10.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.14.4` on cloud_firestore does not support the stable version `0.15.0`.

Try running dart pub upgrade --major-versions cloud_firestore to update the constraint.

The constraint `^0.18.4+1` on firebase_auth does not support the stable version `0.19.0`.

Try running dart pub upgrade --major-versions firebase_auth to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.12, Flutter 3.0.2, Dart 2.17.3.

1
likes
90
pub points
0%
popularity

Publisher

verified publisher iconsonub.com

FireFlutter in-app-purchase package. This package is a submodule of fireflutter.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

cloud_firestore, firebase_auth, flutter, in_app_purchase, rxdart

More

Packages that depend on fireflutter_in_app_purchase