firebase_web 5.0.9

Dart js
Flutter web

Firebase libraries for Dart on the web and server with Cloud Functions

9
likes
90 / 110
pub points
81 %
popularity

We analyzed this package on Sep 25, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 483 out of 626 API elements (77.2 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:firebase_web/firebase.dart that imports:
  • package:firebase_web/src/top_level.dart that imports:
  • package:firebase_web/src/storage.dart that imports:
  • package:firebase_web/src/utils.dart that imports:
  • package:firebase_web/src/interop/js_interop.dart that imports:
  • package:js/js_util.dart that imports:
  • dart:js_util
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: The declaration '_fromJs' isn't referenced.

lib/src/firestore.dart:948:22

    ╷
948 │   factory FieldValue._fromJs(dynamic jsFieldValue) {
    │                      ^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/firestore.dart

INFO: The declaration '_' isn't referenced.

lib/src/firestore.dart:990:14

    ╷
990 │   FieldValue._();
    │              ^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/firestore.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
googleapis_auth^0.2.3+50.2.120.2.12
http>=0.11.3 <0.13.00.12.20.12.2
js^0.6.00.6.20.6.2
service_worker^0.2.00.2.40.2.4
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
http_parser-3.1.43.1.4
meta-1.2.31.2.3
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

9
likes
90
pub points
81%
popularity

Firebase libraries for Dart on the web and server with Cloud Functions

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

choo.yansheng@gmail.com

License

MIT (LICENSE)

Dependencies

googleapis_auth, http, js, service_worker

More

Packages that depend on firebase_web