firebase_storage_image 0.4.0
firebase_storage_image: ^0.4.0 copied to clipboard

Flutter's ImageProvider to use images in Firebase Cloud Storage directly for Image, CircleAvatar, ImageIcon, and something like that.

2
likes
80/ 130
pub points
50%
popularity

We analyzed this package on Oct 22, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 10 API elements (90.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:firebase_storage_image/firebase_storage_image.dart that imports:
  • package:firebase_storage/firebase_storage.dart that declares support for platforms: Android, iOS, macOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/firebase_storage_image.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_core^0.4.0+10.4.51.8.0
firebase_storage^3.0.03.1.610.0.6
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
firebase-7.3.39.0.2
firebase_core_platform_interface-1.0.44.0.1
firebase_core_web-0.1.1+21.1.0
flutter_web_plugins-0.0.00.0.0
http-0.12.20.13.4
http_parser-3.1.44.0.0
js-0.6.30.6.3
matcher-0.12.110.12.11
meta-1.7.01.7.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
plugin_platform_interface-1.0.32.0.2
quiver-2.1.53.0.1+1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.0+1` on firebase_core does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions firebase_core to update the constraint.

The constraint `^3.0.0` on firebase_storage does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions firebase_storage to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0-dev.68.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

2
likes
80
pub points
50%
popularity

Publisher

kohei.dev

Flutter's ImageProvider to use images in Firebase Cloud Storage directly for Image, CircleAvatar, ImageIcon, and something like that.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

firebase_core, firebase_storage, flutter

More

Packages that depend on firebase_storage_image