firebase_remote_helper 0.1.0 icon indicating copy to clipboard operation
firebase_remote_helper: ^0.1.0 copied to clipboard

This plugin makes it easier for you to use firebase remote config.

2
likes
140/ 140
pub points
65%
popularity

We analyzed this package 10 hours ago, and awarded it 140 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 15 API elements (73.3 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ MacOS
  • ✓ Web

These platforms are not supported:

Package does not support platform Windows.

Because:

  • package:firebase_remote_helper/firebase_remote_helper.dart that imports:
  • package:firebase_remote_helper/src/firebase_remote_helper.dart that imports:
  • package:firebase_remote_config/firebase_remote_config.dart that declares support for platforms: Android, iOS, macOS, Web.

Package does not support platform Linux.

Because:

  • package:firebase_remote_helper/firebase_remote_helper.dart that imports:
  • package:firebase_remote_helper/src/firebase_remote_helper.dart that imports:
  • package:firebase_remote_config/firebase_remote_config.dart that declares support for platforms: Android, iOS, macOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:firebase_remote_helper/firebase_remote_helper.dart that imports:
  • package:firebase_remote_helper/src/firebase_remote_helper.dart that imports:
  • package:firebase_remote_config/firebase_remote_config.dart that imports:
  • package:firebase_core_platform_interface/firebase_core_platform_interface.dart that imports:
  • package:firebase_core_platform_interface/src/pigeon/test_api.dart that imports:
  • package:flutter_test/flutter_test.dart that imports:
  • package:flutter_test/src/widget_tester.dart that imports:
  • package:flutter_test/src/test_text_input.dart that imports:
  • package:flutter_test/src/deprecated.dart that imports:
  • package:flutter_test/src/binding.dart that imports:
  • package:flutter_test/src/platform.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_remote_config^3.0.23.0.63.0.6
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_flutterfire_internals-1.0.91.0.9
async-2.9.02.10.0
boolean_selector-2.1.02.1.1
characters-1.2.11.2.1
clock-1.1.11.1.1
cloud_firestore_platform_interface-5.9.05.9.0
cloud_firestore_web-3.1.03.1.0
collection-1.16.01.17.0
fake_async-1.3.11.3.1
firebase_core-2.3.02.3.0
firebase_core_platform_interface-4.5.24.5.2
firebase_core_web-2.0.12.0.1
firebase_remote_config_platform_interface-1.1.261.1.26
firebase_remote_config_web-1.1.151.1.15
flutter_test-0.0.00.0.0
flutter_web_plugins-0.0.00.0.0
js-0.6.40.6.5
matcher-0.12.120.12.13
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
path-1.8.21.8.2
plugin_platform_interface-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.9.01.9.1
stack_trace-1.10.01.11.0
stream_channel-2.1.02.1.1
string_scanner-1.1.11.2.0
term_glyph-1.2.11.2.1
test_api-0.4.120.4.16
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

2
likes
140
pub points
65%
popularity

Publisher

verified publisher iconpub.vursin.com

This plugin makes it easier for you to use firebase remote config.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

firebase_remote_config, flutter

More

Packages that depend on firebase_remote_helper