firebase_remote_config_platform_interface 0.2.0-dev.1
firebase_remote_config_platform_interface: ^0.2.0-dev.1 copied to clipboard

A common platform interface for the firebase_remote_config plugin.

1
likes
100 / 130
pub points
98 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 52 out of 53 API elements (98.1 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 3 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:firebase_remote_config_platform_interface/firebase_remote_config_platform_interface.dart that imports:
  • package:firebase_remote_config_platform_interface/src/platform_interface/platform_interface_firebase_remote_config.dart that imports:
  • package:firebase_remote_config_platform_interface/src/method_channel/method_channel_firebase_remote_config.dart that imports:
  • package:firebase_remote_config_platform_interface/src/method_channel/utils/exception.dart that imports:
  • package:firebase_core/firebase_core.dart that declares support for platforms: Android, iOS, macOS, Web
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_core^1.0.31.0.31.0.3
flutterflutter0.0.00.0.0
meta^1.3.01.3.01.3.0
plugin_platform_interface^2.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
firebase_core_web-1.0.21.0.2
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Package is not null safe

Because:

  • package:firebase_remote_config_platform_interface/firebase_remote_config_platform_interface.dart where package:firebase_remote_config_platform_interface/firebase_remote_config_platform_interface.dart is opting out from null safety.
For more information

Try running pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.