firebase_lumberdash 2.1.0

Flutter Android iOS web

Lumberdash plugin that sends your logs to Firebase Analytics

3
likes
100 / 110
pub points
68 %
popularity

We analyzed this package on Oct 15, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 10 API elements (60.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:firebase_lumberdash/firebase_lumberdash.dart that imports:
  • package:firebase_lumberdash/src/firebase_lumberdash.dart that imports:
  • package:firebase_analytics/firebase_analytics.dart that declares support for platforms: Android, iOS, Web
Package does not support Flutter platform Linux

Because:

  • package:firebase_lumberdash/firebase_lumberdash.dart that imports:
  • package:firebase_lumberdash/src/firebase_lumberdash.dart that imports:
  • package:firebase_analytics/firebase_analytics.dart that declares support for platforms: Android, iOS, Web
Package does not support Flutter platform macOS

Because:

  • package:firebase_lumberdash/firebase_lumberdash.dart that imports:
  • package:firebase_lumberdash/src/firebase_lumberdash.dart that imports:
  • package:firebase_analytics/firebase_analytics.dart that declares support for platforms: Android, iOS, Web
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_analytics^5.0.25.0.166.0.2
flutterflutter0.0.00.0.0
lumberdash^2.1.02.1.12.1.1
meta^1.0.01.3.0-nullsafety.31.3.0-nullsafety.4
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0-nullsafety.3
charcode-1.1.31.2.0-nullsafety.1
collection-1.15.0-nullsafety.31.15.0-nullsafety.3
firebase-7.3.27.3.2
firebase_analytics_platform_interface-1.0.31.0.3
firebase_analytics_web-0.1.10.1.1
flutter_web_plugins-0.0.00.0.0
http-0.12.20.12.2
http_parser-3.1.43.1.4
js-0.6.20.6.2
path-1.7.01.8.0-nullsafety.1
pedantic-1.9.21.9.2
sky_engine-0.0.990.0.99
source_span-1.7.01.8.0-nullsafety.2
string_scanner-1.0.51.1.0-nullsafety.1
term_glyph-1.1.01.2.0-nullsafety.1
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.3
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.3

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.0.2` on firebase_analytics does not support the latest published version `6.0.2`

pubspec.yaml:18:23

   ╷
18 │   firebase_analytics: ^5.0.2
   │                       ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

3
likes
100
pub points
68%
popularity

Publisher

bmwtech.dev

Lumberdash plugin that sends your logs to Firebase Analytics

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

firebase_analytics, flutter, lumberdash, meta

More

Packages that depend on firebase_lumberdash