firebase_in_app_messaging 0.5.0+9
firebase_in_app_messaging: ^0.5.0+9 copied to clipboard

Flutter plugin for Firebase In-App Messaging.

90
likes
110/ 130
pub points
96%
popularity

We analyzed this package on Sep 16, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 8 API elements (50.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:firebase_in_app_messaging/firebase_in_app_messaging.dart that declares support for platforms: Android, iOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_core^1.6.01.6.01.6.0
flutterflutter0.0.00.0.0
meta^1.3.01.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
firebase_core_platform_interface-4.0.14.0.1
firebase_core_web-1.1.01.1.0
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
plugin_platform_interface-2.0.12.0.1
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.1+1, Flutter 2.5.0, Dart 2.14.0.