firebase_functions_interop 1.0.2
firebase_functions_interop: ^1.0.2 copied to clipboard

Firebase Cloud Functions SDK for Dart written as a JS interop wrapper for official Node.js SDK.

24
likes
70 / 130
pub points
81 %
popularity

We analyzed this package on May 8, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 121 out of 166 API elements (72.9 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 41 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/firebase_functions_interop.dart:180:12

    ╷
180 │       return new EventContext._(
    │ ┌────────────^
181 │ │       data.auth,
182 │ │       data.authType,
183 │ │       data.eventId,
184 │ │       data.eventType,
185 │ │       new Map<String, String>.from(dartify(data.params)),
186 │ │       data.resource,
187 │ │       DateTime.parse(data.timestamp),
188 │ │     );
    │ └─────^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/firebase_functions_interop.dart

INFO: Unnecessary new keyword.

lib/firebase_functions_interop.dart:185:7

    ╷
185 │       new Map<String, String>.from(dartify(data.params)),
    │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/firebase_functions_interop.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_admin_interop^1.0.01.2.22.1.0
js^0.6.10.6.30.6.3
meta^1.1.01.3.01.3.0
node_http^1.0.01.0.11.0.1
node_interop^1.0.01.2.12.0.1
node_io^1.0.11.2.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
file-5.2.16.1.0
http-0.12.20.13.3
http_parser-3.1.44.0.0
intl-0.17.00.17.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
quiver_hashcode-2.0.03.0.0+1
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.0.0` on firebase_admin_interop does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions firebase_admin_interop to update the constraint.

The constraint `^1.0.0` on node_interop does not support the stable version `2.0.0`, that was published 25 days ago.

When node_interop is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions node_interop to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0-dev <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

24
likes
70
pub points
81%
popularity

Firebase Cloud Functions SDK for Dart written as a JS interop wrapper for official Node.js SDK.

Homepage

Documentation

API reference

Uploader

anatoly.pulyaevskiy@gmail.com

License

BSD (LICENSE)

Dependencies

firebase_admin_interop, js, meta, node_http, node_interop, node_io

More

Packages that depend on firebase_functions_interop