firebase_database_web 0.2.5+9 copy "firebase_database_web: ^0.2.5+9" to clipboard
firebase_database_web: ^0.2.5+9 copied to clipboard

Platformweb
unlisted

The web implementation of firebase_database

1
likes
130/ 160
pub points
89%
popularity

We analyzed this package 4 days ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

58 out of 69 API elements (84.1 %) have documentation comments.

Some symbols that are missing documentation: firebase_database_web, firebase_database_web.DataSnapshotWeb.child, firebase_database_web.DataSnapshotWeb.children, firebase_database_web.DataSnapshotWeb.exists, firebase_database_web.DataSnapshotWeb.priority.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Web

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:firebase_database_web/firebase_database_web.dart that declares support for platforms: Web.
Package does not support platform `iOS`.

Because:

  • package:firebase_database_web/firebase_database_web.dart that declares support for platforms: Web.
Package does not support platform `Windows`.

Because:

  • package:firebase_database_web/firebase_database_web.dart that declares support for platforms: Web.
Package does not support platform `Linux`.

Because:

  • package:firebase_database_web/firebase_database_web.dart that declares support for platforms: Web.
Package does not support platform `macOS`.

Because:

  • package:firebase_database_web/firebase_database_web.dart that declares support for platforms: Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:firebase_database_web/firebase_database_web.dart that imports:
  • package:firebase_database_web/src/interop/database.dart that imports:
  • package:firebase_database_web/src/interop/database_interop.dart that imports:
  • package:firebase_core_web/firebase_core_web_interop.dart that imports:
  • package:firebase_core_web/src/interop/core.dart that imports:
  • package:firebase_core_platform_interface/firebase_core_platform_interface.dart that imports:
  • package:firebase_core_platform_interface/src/pigeon/test_api.dart that imports:
  • package:flutter_test/flutter_test.dart that imports:
  • package:flutter_test/src/widget_tester.dart that imports:
  • package:flutter_test/src/test_text_input.dart that imports:
  • package:flutter_test/src/test_text_input_key_handler.dart that imports:
  • package:flutter_test/src/binding.dart that imports:
  • package:flutter_test/src/platform.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/src/data_snapshot_web.dart:5:1

  ╷
5 │ part of firebase_database_web;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/data_snapshot_web.dart

INFO: The part-of directive uses a library name.

lib/src/database_event_web.dart:5:1

  ╷
5 │ part of firebase_database_web;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/database_event_web.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.18.0 1.18.0 1.19.0
firebase_core ^3.1.0 3.1.0 3.1.0
firebase_core_web ^2.17.2 2.17.2 2.17.2
firebase_database_platform_interface ^0.2.5+37 0.2.5+37 0.2.5+37
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
_flutterfire_internals - 1.3.37 1.3.37
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
fake_async - 1.3.1 1.3.1
firebase_core_platform_interface - 5.1.0 5.1.0
flutter_test - 0.0.0 0.0.0
leak_tracker - 10.0.4 10.0.5
leak_tracker_flutter_testing - 3.0.3 3.0.5
leak_tracker_testing - 3.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.2
vector_math - 2.1.4 2.1.4
vm_service - 14.2.1 14.2.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.